Destroy FX system requirements



Audio Unit plugins for Mac OS X

  mac_au icon   mac_au icon 2

Our Audio Unit plugins for Mac OS X require Mac OS X 10.3.9 ("Panther") or higher. They run natively on PowerPC-based Macs and Intel-based Macs. They are currently only available for 32-bit environments.

The only exceptions are RMS Buddy versions 1.1 and 1.1.1, which run in Mac OS X 10.2 ("Jaguar") or higher (and do not contain executable code for Intel processors), and Turntablist, which requires Mac OS X 10.4 ("Tiger") or higher. Skidder and Freeverb will also run in 64-bit environments.

VST plugins for Windows

  windows icon

Our VST plugins for Windows require Windows 95 or higher. They are currently only available for 32-bit environments.

VST plugins for Mac OS X

  mac_vst icon

Our VST plugins for Mac OS X require Mac OS X 10.1 ("Puma") or higher. They are CFM code format for PowerPC processors. They may run under the "Rosetta" environment for Intel processors, but they do not contain native x86 executable code, nor are they available in the native Mac OS X code format Mach-O (we made the decision to discontinue VST development for Mac before Steinberg released their woefully belated VST SDK for Mach-O).

VST plugins & applications for old Mac OS

  oldmac_vst icon

Our software for old Mac OS will run in Mac OS versions 8.5 through 9.2.2.

  Destroy FX: a Smartelectronix member